Konfigurasi Queue Tree pada Mikrotik

February 24th, 2012 No comments

Banyak keluhan taman2 mengenai cara pengaturan bandwidth menggunakan Mikrotik.  Sebenarnya gampang.  Berikut ini script yang saya adopsi dari link yang lain, dan sayapun sudah menerapkannya.

Langkah 1: Lakukan konfigurasi pada Mangle

Pertama kita mark packet untuk UPLOAD dari semua IP Address yang ada :

:for x from=1 to=254 do={ /ip firewall mangle add chain=prerouting src-address=”192.168.1.$x” action=mark-packet new-packet-mark=”U_PC_$x” passthrough=no }

Sedikit penjelasan script diatas :
Variable “x” dri 1-254, dalam src-address kita input class IP yang kita punya di ikuti variable yang kita buat. Trus kita mark-packet dengan nama “U_PC_$x” $x akan otomatis terisi variable yang kita buat yaitu dari 1-254

Kedua kita mark packet untuk DOWNLOAD dari semua IP Address yang ada :

:for x from=1 to=254 do={ /ip firewall mangle add chain=postrouting src-address=”192.168.1.$x” action=mark-packet new-packet-mark=”D_PC_$x” passthrough=no }

Perubahannya hanya pada chain dan nama paket, konsepnya sama kyk diatas

Langkah 2 : Konfigurasi Queue Tree

Sekarang kita buat top parent pada queue tree untuk digunakan mangle diatas :

/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=256k name=Upload packet-mark=”" parent=WAN priority=8 queue=default;
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1024k name=Download packet-mark=”" parent=LAN priority=8 queue=default;

Untuk “max-limit” sesuaikan dengan total bandwidth yang anda terima dari ISP, harus sama atau kurang dari total bandwidth. Jangan lebih karena queue tidak akan berjalan baik. Untuk “parent” sesuaikan dengan nama interfaces di mikrotik anda.

Lanjut kita buat script otomatis yang akan membuat queue masing-masing IP pada top parent di atas

:for x from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=32k max-limit=256k name=”U_PC_$x” packet-mark=”U_PC_$x” parent=Upload priority=8 queue=default }
:for x from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128k max-limit=1024k name=”D_PC_$x” packet-mark=”D_PC_$x” parent=Download priority=8 queue=default }

Untuk limit-at dan max-limit setiap IP Address anda bisa sesuaikan sesuai kebutuhan

Akhirnya mangle atau queue akan terbuat otomatis dari IP 192.168.1.1 – 192.168.1.254 dengan menjalankan script diatas.

Categories: Tutorial Pemrograman Tags:

Konfigurasi Transparent Proxy pada Squid 3.1.16

February 24th, 2012 No comments

Kali ini saya mau berbagi pengalaman saya dalam hal konfigurasi Transparent Proxy pada Squid 3.1.16.  Saya sedikit kerepotan, karena sedikit agak berbeda dengan konfigurasi versi sebelumnya.  Maklumlah, saya sudah lama menggunakan Squid versi 2.5.  Ternyata, konfigurasinya sederhana.

Berikut ini konfigurasi pada Squid server saya :

# Squid normally listens to port 3128
http_port 3128 transparent vhost vport=80 defaultsite=virtual
always_direct allow localnet
dns_nameservers 10.200.200.200 10.200.200.201

# Uncomment and adjust the following to add a disk cache directory.
cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid

 

#Kemudian, tambahkan konfigurasi Delay Pool supaya tidak tersedot bandwidth akibat proses download file yang berukuran besar

delay_pools 2
delay_class 1 3
delay_class 2 3
delay_parameters 1 64/64000 64/64000 64/64000
delay_parameters 2 1/1 1/1 1/1

#Pool 1
acl filegede url_regex -i \.mp3$ \.rm$ \.mpg$ \.mpeg$ \.avi$ \.dat$ \.zip$ \.rar$ \.rpm$ \.gz$ \.bz2$ \.exe$ \.iso$ \.raw$ \.ram$ \.wav$ \.vqf$
delay_access 1 allow filegede
delay_access 1 deny localnet

#Pool 2
acl filesharing url_regex -i 2shared.com 4shared.com depositfiles.com easy-share.com filefactory.com fileserve.com filesonic.com hotfile.com letitbit.net megashares.com megaupload.com oron.com rapidshare.com rapidshare.de sharingmatrix.com turbobit.net uploaded.to uploading.com uploadstation.com wupload.com zshare.net
delay_access 2 allow filesharing
delay_access 2 deny localnet

 

Selanjutnya, perlu dilakukan konfigurasi pada IPTables.  Konfigurasinya kira2 sebagai berikut:

*nat
:P REROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [2:120]
:P OSTROUTING ACCEPT [0:0]
-A PREROUTING -i eth1 -p tcp -m tcp –dport 80 -j REDIRECT –to-ports 3128
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT
# Completed on Tue Feb 21 13:46:47 2012
# Generated by iptables-save v1.4.9 on Tue Feb 21 13:46:47 2012
*mangle
:P REROUTING ACCEPT [188:26962]
:INPUT ACCEPT [119:12434]
:FORWARD ACCEPT [69:14528]
:OUTPUT ACCEPT [217:18226]
:P OSTROUTING ACCEPT [286:32754]
COMMIT
# Completed on Tue Feb 21 13:46:47 2012
# Generated by iptables-save v1.4.9 on Tue Feb 21 13:46:47 2012
*filter
:INPUT ACCEPT [122:12554]
:FORWARD ACCEPT [69:14528]
:OUTPUT ACCEPT [223:19257]
-A INPUT -p tcp -m state –state NEW -m tcp –dport 22 -j ACCEPT

-A FORWARD -i eth1 -p tcp -m tcp –dport 53 -j ACCEPT
-A FORWARD -i eth1 -p tcp -m tcp –dport 110 -j ACCEPT
-A FORWARD -i eth1 -p tcp -m tcp –dport 443 -j ACCEPT

#Memblokir seluruh port selain port diatas
-A FORWARD -i eth1 -p tcp –destination-port 0:65535 -j DROP
-A FORWARD -i eth1 -p udp –destination-port 0:65535 -j DROP
COMMIT
# Completed on Tue Feb 21 13:46:47 2012

 

Dan jangan lupa mengeset nilai pada ip_forward

echo ’1′ > /proc/sys/net/ipv4/ip_forward

 

Terus, kadang-kadang juga harus menambahkan routing (opsional).  Sintaks untuk routing, misalnya :

route add default gw 202.58.180.217 eth0
route add -net 10.0.0.0/8 gw 10.200.202.1 eth1

Sederhana kan?

Categories: Tutorial Pemrograman Tags:

Faktor Kegagalan Pengembangan Aplikasi (1) : Sikap Arogansi

December 18th, 2011 No comments

Beberapa hari yang lalu, saya ikut meeting dengan salah seorang Project Manager sebuah perguruan tinggi.   Meeting saat itu adalah membahas mengenai Rencana Pengembangan dan Implementasi TI 2012.  Biasa, kita ingin mengetahui planning apa yang ingin dicapai.  Sebelum meeting dimulai, saya sempat dengar obrolan dengan staf bawahannya kalau nantinya, salah satu sistem yang akan diusulkan, hanya merubah skin-nya saja tanpa ada perubahan terhadap isinya.  Artinya, kulitnya aja yang berubah.

Saya tahu persis apa yang mereka sedang bicarakan, bahwa sistem yang sedang berjalan, yang banyak masalah itu dan yang “super lambat” kalau diakses, akan dimodifikasi untuk diterapkan di area unit bisnis saya.

Saat mulai dia paparkan, sayapun mengusulkan untuk me-review sistem yang mereka tawarkan tersebut agar tidak memindahkan masalah ke unit bisnis tempat saya kerja.  Kalau memang perlu, ya dirombak ulang.  Syukurlah, dia sadar akan argumen saya.  Hanya, dia berdalih kalau sistem tersebut akan diperbaiki.  Sikapnya agak sedikit marah.

Dari sikapnya si Pimpro tersebut, membuat saya tidak simpatik.  Sikap arogansi si Pimpro itu juga menjadi salah satu yang membuat saya tidak simpatik dari dulu.  Dalam hal komunikasi, kadang suka memvonis kalau solusi yang terbaik adalah pendapatnya.  Ya, saya tahu alasannya dia bisa arogan, dia gak pernah mengerjakan proyek diluar, gak punya pengalaman, sehingga kalau dikasih masukan, seolah-olah dia lebih tahu.  Nah ini dia, sikap “kodok dalam tempurung”, dan yang hanya berpikir untuk jangka pendek.

Contoh tersebut diatas adalah salah satu sikap team developer yang nota bene hanya berpikir untuk jangka pendek.  Artinya, hanya menyenangkan user dengan tampilan, bukan dengan content.  Tidak memperhatikan, betapa sering pengguna komplain.  Saking sering komplain, nyaris tidak pernah ada komplain lagi karena malas untuk komplain.

Menurut saya, ini menjadi salah satu fakto kegagalan pengembangan sistem.   Bagaimana pendapat anda?

Categories: Motivasi Tags:

Tantangan Teknologi Informasi

May 17th, 2011 No comments

Sudah banyak software atau perangkat lunak yang tersedia di pasar, dan tak sedikit juga tenaga profesional yang siap pakai.  Namun, persoalan tak kunjung habis.  Masalah demi masalah semakin bermunculan, kehadiran teknologi seakan tak mampu menjawab.  Apa penyebabnya?  Karena teknologi tidak beradaptasi atau karena manusia tak mampu memanfaatkan teknologi?

Ada 4 hal yang menjadi tantangan profesi saat ini, yakni :

  1. Memberdayakan kemampuan tenaga profesi untuk menghasilkan produk-produk software yang bermanfaat.  Tidak perlu canggih-canggih, namun produk tersebut mampu mengerjakan pekerjaan harian, dan meningkatkan efisiensi.  Kita bangga sebagai anak bangsa, karena sesungguhnya kita mampu mengerjakan tantangan yang lebih besar
  2. Negara kita penuh dengan korupsi.  Kita harus mampu mengatasi persoalan ini melalui aplikasi TI yang mengolah data yang bersifat stratejik, mulai dari pengurusan surat RT/RW, KTP, pengadaan barang, tender, lelang, dan lain-lain.  Yang jelas, Kita menginginkan Clean Goverment.
  3. Tenaga Profesi yang lebih terampil.  Hari ini saya baca di detik.com, bahwa pemerintah Dubai ingin merekrut tenaga teknik dari Indonesia sebanyak 95 orang.  Wow, jumlah yang banyak.  Negara-negara Eropa ternyata mengakui kemampuan bangsa kita.  Kalau jadi, maka mereka yang kesana adalah tenaga trampil yang siap pakai.   Masih ada sekita 170juta tenaga muda yang harus dididik.
  4. Pemerintah dan lembaga swasta harus menghargai keberadaan tenaga profesi lokal.  Sudah menjadi rahasia umum, kalau tenaga profesi IT di Indonesia tidak dihargai secara seimbang.  Tenaga profesi IT di Indonesia hanya dipandang sebagai support saja.

Ini bukan hanya tanggungjawab perorangan, tapi tanggungjawab bersama.

Categories: Motivasi Tags: , ,

Perubahan dan Tantangan

May 16th, 2011 No comments

BISTEKINDO adalah layanan yang bergerak dalam bidang jasa konsultasi teknologi informasi.  Melihat tantangan dunia yang semakin besar, kami siap membantu dengan memberikan pelayanan terbaik dengan ditangani oleh tenaga-tenaga profesional yang telah memiliki pengalaman dalam bidang teknologi informasi.

Kami berusaha untuk memahami kondisi, budaya dan prinsip kerja perusahaan dengan metode “manajemen perubahan” pada perencanan, analisa, perancangan dan implementasi.

Categories: Motivasi Tags: